DYNDNS in Mikrotik (ddns.info) - Об ОС *Nix - Системное администрирование - Каталог статей - Архив документации и мануалов для админов

Воскресенье, 11.12.2016, 13:49
Приветствую Вас Гость | RSS
Мой сайт
Главная
Регистрация
Вход
Форма входа

Меню сайта

Категории раздела
Об ОС Windows [137]
В категории размещаются статьи, касающщиеся операционных систем от Microsoft.
Об ОС *Nix [198]
В данной категории собраны статьи об ОС семейства Unix/Linux/FreeBSD/...
Справочные материалы [351]
Справка по всему разделу.
Виртуализация и Облака [46]
Networks & Routing [86]
DataBases [22]

Наш опрос
Оцените мой сайт
Всего ответов: 193

Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0

Главная » Статьи » Системное администрирование » Об ОС *Nix

DYNDNS in Mikrotik (ddns.info)
Дело в следующем. Нужно было сделать удаленное админование для Микротика. Встроенного DynDNS клиента в нем нет. Но выход всё-же есть. Нашел инфо на одном форуме, доработал - запахало! В общем вот ман, если кому нужно.
Регистрируемся на сайте ddns.info. Делаем себе бесплатное доменное имя. Далее в шедулер Микротика добавляем два задания (скрипта):

:local CurrentDynDNSIP [:resolve YourDDNS.ddns.info]
:local TMPDynDNSIP [/ip address get [/ip address find interface=интерфейс] address]
:local RealDynDNSIP [:pick $TMPDynDNSIP 0 ([:len $TMPDynDNSIP]-3)]
#:log info ("CurrentDynDNSIP = " . $CurrentDynDNSIP)
#:log info ("TMPDynDNSIP = " . $TMPDynDNSIP)
#:log info ("RealDynDNSIP-adr = " . $RealDynDNSIP)
:if ($CurrentDynDNSIP != $RealDynDNSIP) do={/
tool dns-update name=YourDDNS.ddns.info address=$RealDynDNSIP key-name=логин key=пароль}

и

:local CurrentDynDNSIP [:resolve www.YourDDNS.ddns.info]
:local TMPDynDNSIP [/ip address get [/ip address find interface=интерфейс] address]
:local RealDynDNSIP [:pick $TMPDynDNSIP 0 ([:len $TMPDynDNSIP]-3)]
#:log info ("CurrentDynDNSIP = " . $CurrentDynDNSIP)
#:log info ("TMPDynDNSIP = " . $TMPDynDNSIP)
#:log info ("RealDynDNSIP-adr = " . $RealDynDNSIP)
:if ($CurrentDynDNSIP != $RealDynDNSIP) do={/
tool dns-update name=www.YourDDNS.ddns.info address=$RealDynDNSIP key-name=логин key=пароль}


Где YourDDNS.ddns.info - Ваше бесплатное доменное имя.
Интерфейс - интерфейс на котором висит инет, у меня в его роли PPPoE соединение

Разница второго и первого скрипта в том, что мы дописали три чудо буквы www во втором скрипте, в первой и предпоследней строчке.


Смысл таков. Микротик сверяет ИП который у него сейчас с ИПом, который подхватил сайт. Если ИП разные, то на сайт отсылается новый ИП. Время, через которая происходит проверка выставляется шедулером. У меня каждые 2 минуты. Но есть один ньюанс. Если мы в адресной строке наберем имя нашего хоста без www, то получим х... Таковы особенности сайта ddns.info

Источник: http://local.com.ua/forum/topic/14095-dyndns-%D0%B2-%D0%BC%D0%B8%D0%BA%D1%80%D0%BE%D1%82%D0%B8%D0%BA/
Категория: Об ОС *Nix | Добавил: admin (09.06.2011)
Просмотров: 3049 | Теги: mikrotik, route, dyndns | Рейтинг: 0.0/0
Всего комментариев: 0
Имя *:
Email *:
Код *:
Поиск

Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz


  • Copyright MyCorp © 2016