VLAN в ProCurve - Справочные материалы - Системное администрирование - Каталог статей - Архив документации и мануалов для админов

Четверг, 08.12.2016, 13:50
Приветствую Вас Гость | RSS
Мой сайт
Главная
Регистрация
Вход
Форма входа

Меню сайта

Категории раздела
Об ОС Windows [137]
В категории размещаются статьи, касающщиеся операционных систем от Microsoft.
Об ОС *Nix [198]
В данной категории собраны статьи об ОС семейства Unix/Linux/FreeBSD/...
Справочные материалы [351]
Справка по всему разделу.
Виртуализация и Облака [46]
Networks & Routing [86]
DataBases [22]

Наш опрос
Оцените мой сайт
Всего ответов: 193

Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0

Главная » Статьи » Системное администрирование » Справочные материалы

VLAN в ProCurve

VLAN в ProCurve

Share/Save/Bookmark
Короткий URL: vlan/procurve

На этой странице рассматривается процедура настройки VLAN в HP ProCurve.

<VLAN

Содержание

 [убрать]

[править]Настройка VLAN на коммутаторах HP ProCurve

Сеть с VLANами на коммутаторах ProCurve

По умолчанию на коммутаторах HP ProCurve доступно не максимальное количество VLAN. Как правило, можно создать 8 VLAN. Это можно изменить с помощью команды max-vlans. Указание максимального количества VLAN (максимальное значение варьируется в зависимости от модели коммутатора):

sw1(config)# max-vlans <количество VLAN>

Для применения этой команды необходимо сохранить конфигурацию и перезагрузить коммутатор.

Создание VLAN'а, задание имени и назначение портов:

sw1(config)# vlan 2
sw1(vlan-2)# name test
sw1(vlan-2)# untagged 1,2
sw1(vlan-2)# tagged 22
sw1(config)# vlan 10
sw1(vlan-10)# untagged 4-5
sw1(vlan-10)# tagged 22 

Так как на коммутаторе sw2 нет VLAN'а 15, то мы не добавляем тегированный порт 22 в этот VLAN:

sw1(config)# vlan 15
sw1(vlan-15)# untagged 3

Просмотр информации о существующих VLAN'ах:

sw1# sh vlan

 Status and Counters - VLAN Information

 Maximum VLANs to support : 256 
 Primary VLAN : DEFAULT_VLAN
 Management VLAN : 

 VLAN ID Name | Status Voice Jumbo
 ------- -------------------- + ---------- ----- -----
 1 DEFAULT_VLAN | Port-based No No 
 2 test | Port-based No No 
 10 VLAN10 | Port-based No No 
 15 VLAN15 | Port-based No No 

Посмотреть, какие порты принадлежат VLAN'у 2 и какой статус у порта:

sw1# sh vlan 2

 Status and Counters - VLAN Information - Ports - VLAN 2

 VLAN ID : 2 
 Name : test 
 Status : Port-based
 Voice : No 
 Jumbo : No 

 Port Information Mode Unknown VLAN Status 
 ---------------- -------- ------------ ----------
 1 Untagged Learn Up 
 2 Untagged Learn Up 
 22 Tagged Learn Up 
 

Посмотреть, каким VLAN'ам принадлежит порт 22:

sw1# sh vlan port 22

 Status and Counters - VLAN Information - for ports 22

 VLAN ID Name | Status Voice Jumbo
 ------- -------------------- + ---------- ----- -----
 1 DEFAULT_VLAN | Port-based No No 
 2 test | Port-based No No 
 10 VLAN10 | Port-based No No 
 

Конфигурация sw1:

vlan 1 
 name "DEFAULT_VLAN" 
 untagged 6-24 
 ip address dhcp-bootp 
 no untagged 1-5 
 exit 
vlan 2 
 name "test" 
 untagged 1-2 
 tagged 22 
 no ip address 
 exit 
vlan 10 
 name "VLAN10" 
 untagged 4-5 
 tagged 22 
 no ip address 
 exit 
vlan 15 
 name "VLAN15" 
 untagged 3 
 no ip address 
 exit 

[править]Настройка маршрутизации между VLAN

Дальнейшие настройки подразумевают использование коммутатора 3 уровня.

Для того чтобы настроить маршрутизацию между сетями разных VLAN на коммутаторе необходимо:

  1. Включить ip routing
  2. Назначить IP-адреса соответствующим VLAN

Кроме того, необходимо чтобы IP-адреса соответствующих VLAN были указаны как маршруты по умолчанию на хостах.

Включение маршрутизации на коммутаторе:

sw(config)# ip routing

Задание адреса в VLAN. Этот адрес должен быть прописан как маршрут по умолчанию для компьютеров в VLAN 2:

sw(config)# vlan 2
sw(vlan-2)# ip address 10.0.2.1/24

Или, другой формат задания IP-адреса в VLAN:

sw(config)# vlan 2 ip address 10.0.2.1/24

Просмотр информации о заданных IP-адресах и включен ли ip routing:

sw(config)# show ip

Таблица маршрутизации:

sw(config)# show ip route

[править]Пример конфигурации

Для сети изображенной на схеме приведены примеры конфигураций коммутаторов.

Коммутаторы sw1 и sw2 работают как коммутаторы 2 уровня. Коммутатор sw3 выполняет маршрутизацию между VLAN'ами хостов и серверным. Кроме того, на коммутаторе sw3 настроен DHCP relay agent, для того чтобы хосты могли получить IP-адреса и маршрут по умолчанию от DHCP-сервера (IP-адрес DHCP-сервера указан на схеме).

Конфигурация sw1:

hostname "sw1" 
vlan 11
 name "marketing" 
 untagged 1-2 
 tagged 11 
 exit 
vlan 12
 name "managers" 
 untagged 7-8
 tagged 11
 exit 

Конфигурация sw2:

hostname "sw2" 
vlan 11
 name "marketing" 
 untagged 3-4 
 tagged 12
 exit 
vlan 15
 name "top-managers" 
 untagged 8-9
 tagged 12
 exit 

Конфигурация sw3:

hostname "sw3" 
ip routing
vlan 11
 name "marketing"
 ip address 10.0.11.1 255.255.255.0
 ip helper-address 10.0.100.100
 tagged 11-12
 exit 
vlan 12
 name "managers"
 ip address 10.0.12.1 255.255.255.0
 ip helper-address 10.0.100.100
 tagged 11
 exit 
vlan 15
 name "top-managers"
 ip address 10.0.15.1 255.255.255.0
 ip helper-address 10.0.100.100
 tagged 12
 exit 
vlan 100
 name "servers"
 ip address 10.0.100.1 255.255.255.0
 untagged 1-2
 exit 

[править]Настройка VLAN на маршрутизаторах ProCurve

Настройка физического интерфейса:

R1(config)#interface eth 0/1
R1(config-eth 0/1)#encapsulation 802.1q

После задания на физическом интерфейсе инкапсуляции 802.1Q на нем нельзя задать IP-адрес (адреса задаются на подынтерфейсах).

На логических подынтерфейсах необходимо указать номер VLAN и адрес. Если подынтерфейс должен передавать нетегированный трафик, то необходимо использовать опцию native (по умолчанию native VLAN 1).

Создание логического подынтерфейса для VLAN 1:

R1(config)#int eth 0/1.1 
R1(config-eth 0/1.1)#vlan-id 1 native 
R1(config-eth 0/1.1)#ip address 10.0.1.1 /24

Создание логического подынтерфейса для VLAN 2:

R1(config)#int eth 0/1.2 
R1(config-eth 0/1.2)#vlan-id 2 
R1(config-eth 0/1.2)#ip address 10.0.2.1 /24

Пример конфигурации R1:

!
interface eth 0/1
 encapsulation 802.1q
 no shutdown
!
interface eth 0/1.1
 vlan-id 1 native
 no shutdown
 ip address 10.0.1.1 255.255.255.0 

interface eth 0/1.2
 vlan-id 2
 no shutdown
 ip address 10.0.2.1 255.255.255.0 

interface eth 0/1.10
 vlan-id 10
 no shutdown
 ip address 10.0.10.1 255.255.255.0 

interface eth 0/1.15
 vlan-id 15
 no shutdown
 ip address 10.0.15.1 255.255.255.0 



Источник: http://xgu.ru/wiki/VLAN_%D0%B2_ProCurve
Категория: Справочные материалы | Добавил: admin (05.10.2011)
Просмотров: 2977 | Комментарии: 1 | Теги: HP, Switch, config, procurve, vlan | Рейтинг: 0.0/0
Всего комментариев: 0
Имя *:
Email *:
Код *:
Поиск

Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz


  • Copyright MyCorp © 2016