Среда, 08.05.2024, 21:56
Приветствую Вас Гость | RSS
Мой сайт
Главная
Регистрация
Вход
Форма входа

Меню сайта

Категории раздела
Об ОС Windows [137]
В категории размещаются статьи, касающщиеся операционных систем от Microsoft.
Об ОС *Nix [198]
В данной категории собраны статьи об ОС семейства Unix/Linux/FreeBSD/...
Справочные материалы [351]
Справка по всему разделу.
Виртуализация и Облака [46]
Networks & Routing [86]
DataBases [22]

Наш опрос
Оцените мой сайт
Всего ответов: 209

Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0

Главная » Статьи » Системное администрирование » Справочные материалы

Mikrotik DUAL WAN Load Balancing using PCC method. Complete Script ! by zaiB
Mikrotik  DUAL WAN Load Balancing using PCC method. Complete Script ! by zaiB

Following is a complete script for Mikrotik to combine/load balance two DSL lines. In this example I used MikrotikT RB750 5 ports router.

2 ports were connected with two difference DSL Routers,
and 3rd port was connected with User LAN.
Both DSL are of same speed , i.e 10Mb each.

DSL MODEM IP’S
DSL MODEM 1 = 192.168.1.1
DSL MODEM 2 = 192.168.2.1

Also don’t forget to rename the interface names accordingly.

In my personnel experience , If users request are directly hitting Mikrotik configured with PCC , then you will get good load balancing. Use src-address as classifier, this way you will get rid of problems like https/broken link, streaming issues etc. Load balancing using this PCC technique (src-address) will be effective and balanced approach when more and more connections (from clients) that occurred. I also recommend to use SQUID proxy server along with mikrotik , either parallel or in front or backend , for better response time and it will also increase good browsing experience to users.

If somehow you are not satisfied with the src-address approach,play with the PCC-Classifier, then Try both addresses and ports as the classifier. While this will randomize things the most and in theory give you the most fair allocation of bandwidth, BUT there is also a good chance that it will break certain things like banking web sites and some forums. This is because often times a HTTP requests will generate several connections, so there is a chance that some requests may go out a different route than the initial one, and that will break secure web sites. For that reason I usually stick with src-address for PCC load balancing.

Regard’s
Syed Jahanzaib

01/ip address
02add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
03add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
04add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2
05 
06/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=221.132.112.8,8.8.8.8
07 
08/ip firewall mangle
09add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
10add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
11 
12add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
13add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2
14 
15add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
16add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local
17 
18add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
19add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
20 
21add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
22add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2
23 
24/ip route
25add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping
26add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping
27 
28add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
29add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping
30 
31/ip firewall nat
32add chain=srcnat out-interface=WAN1 action=masquerade
33add chain=srcnat out-interface=WAN2 action=masquerade

All Done ! Now Test the link by putting user load, the more multiple users load you put on it, the better Load Balance result you will get :)

PCC WITH UN-EQUAL WAN LINKS

If you have Un-Equal WAN Links, for example WAN,1 is of 4MB and WAN,2 is of 8 Mb, and you want to force MT to use WAN42link more then other because of its capacity, Then you have to Add more PCC rules assigning the same two marks to a specific link i.e WAN2 , something like

Code:

1add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
2add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
3add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/2 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

PCC WITH HOTSPOT (Reference)

1/ip firewall nat add action=accept chain=pre-hotspot disabled=no dst-address-type=!local hotspot=auth




Источник: http://aacable.wordpress.com/2011/07/27/mikrotik-dual-wan-load-balancing-using-pcc-method-complete-script-by-zaib/
Категория: Справочные материалы | Добавил: admin (17.07.2012)
Просмотров: 33152 | Комментарии: 1 | Теги: daul, Balance, mikrotik, wan | Рейтинг: 0.0/0
Всего комментариев: 1
1 Кондиционеры в Москве.  
Приветствую!
Недавно я нашёл очень милый интернет магазин АКА Климат, в нем кондиционеры, по отличным ценам, не проходите
мимо, классная фирма! http://akaklimat.ru/
Всем пока!

Имя *:
Email *:
Код *:
Поиск

Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz


  • Copyright MyCorp © 2024